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INTRODUCTION

The Build and Integration Framework for Automotive Controller Embedded Software (BIFACES) from Infineon, is an
internally developed build framework for Infineon automotive micro-controllers' software development. This application
note describes how you can migrate a project created with Infineon's BIFACES to the TASKING VX-toolset for TriCore
Eclipse IDE.

The benefits of using the TASKING VX-toolset for TriCore Eclipse IDE instead of BIFACES is that you have full control over the
tool options through the graphical Eclipse user interface. The integrated Pin Mapper eases pin status configuration. You
also have direct access to the integrated debugger. Your complete development integrated environment all in one place.

In this application note we assume that you are familiar with BIFACES and already have it installed by following the
BIFACES User Manual. We also assume you have installed the Base Projects you want to migrate from.

The following BIFACES downloads from https://myicp.infineon.com are assumed in this application note, but of
course the same guidelines can be followed for newer versions:

Infineon download Description

BIFACES_V1_0_2_Win32.zip BIFACES V1.0.2 for Windows 32-bit
BIFACES_V1_0_2_Win64.zip BIFACES V1.0.2 for Windows 64-bit

BaseProjects_AURIX1G_V1_0_1_11_0.zip BIFACES Base Projects for AURIX devices based on iLLD
V1.0.1.11.0. Supported devices:

+ TC21A
+ TC22A
+ TC23A
+ TC26B
+ TC27C
+ TC27D
+ TC29B

BaseProjects_AURIX2G_V1_0_1_11_0.zip BIFACES Base Projects for AURIX 2G devices based on
iLLD V1.0.1.11.0. Supported devices:

+ TC33A

* TC33AED
+ TC35xA
+ TC36A

+ TC37xA
+ TC38A

+ TC39B

These versions work together with the TASKING VX-toolset for TriCore v6.3r1.
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PREPARING THE BIFACES BASE PROJECTS
1. Install BIFACES (either the 32-bit or 64-bit version) and the BFACES Base Projects according to the BIFACES User
Manual if you have not done so already.

2. Start BIFACES by double-clicking on StartBifases.bat inthe BifacesWin32 or BifacesWin64 directory,
depending on which version you installed.

@U?‘ . v Computer » Local Disk (C:) » Tools » BifacesWin32 »

Organize « @ Open Print Burn Mew folder

. Tools i Narne Date modified Type Size
Bifaces\Win32
| Bifaces File folder
. Bifaces
. . bin File folder
. bin X
. DocTools File folder
. DocTools
: eclipse File folder
. eclipse
. OsTools File folder
OsTools = :
o T . Php : File folder
it ) BIFACES_UserManual.pdf 1/ 8343 PM Adobe Acrobat D... 2,068 KB
45| StartBifaces.bat 8/19/2019 3:15 PM Windows Batch File 1KE
‘2| StartBifacesDos.bat 8/19/2019 3:14 PM Windows Batch File 1KB

Figure 1: Start BIFACES

3. Select the workspace where you installed the Base Projects and click Launch:

& Eclipse Launcher @
Select a directory as workspace

Eclipse Platform uses the workspace directory to store its preferences and development artifacts.

Workspace:  C\Users\name\Bifaces_Auri2G_Workspace V1 0.1 11 0 - Browse...

[] Use this as the default and do not ask again

b Recent Workspaces

Launch ] [ Cancel

Figure 2: Select workspace
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4. Click F5 or select File -> Refresh to refresh the content of the Project Explorer view.

5. Editfile Config Tasking.mk inBaseFramework TC39B\1 ToolEnv\0 Build\1l Config\Config Tricore
Tasking and change the variable B TASKING TRICORE PATH to the path where your TASKING VX-toolset for TriCore
v6.3r1 is located. For example:

B TASKING TRICORE PATH= C:\TriCore vé6.3rl\ctc

2 Bifaces_Aurix2G_Workspace_V1_0_1_11 0 - BaseFramework_TC39B/1_ToolEnw/0_Build/1_Config/Config_Tricore_Tasking/Config_Tasking.mk - Eclipse Platform ==

File Ecit Navigate Search Project Run Window Help
=~ B @A iE il Hr oD Quick Access ;| 5 |
[ Project Explorer 52 = 5| & T = B [ Config Tasking.mk 3 = B8
» (5 BaseFramework_TC38A - = -
4 &5 BaseFramework_TC398 s
. = 0 Src :

4 = 1 ToolEny .

4 (= 0_Build M

4 (= 1_Config #

, (= Config_Tricore_Dec #

. = Config_Tricore_Ghs :

» & Config_Tricore_Gnuc M
#

#

#

#

#

#

#

#

Copyright (c) 2018 Infineon Technologies AG

IMPORTANT NOTICE

file for use
This file can be
e supperting such

4 [>2 Config_Tricore_Tasking L
:
|@] Lef_Tasking_Tricore_Te.lsl
[¥] BifacesConfigaxsd
& Config.mk
[¥] Configaxml

T Makefile

5= Qutline 52 #% =8
B_TASKING_TRICORE_PATH
B_TASKING_TRICORE_CC_OPTI ... B_TASKING_TRICORE_CC_OPTIONS= --core=tc1.6.2 --iso=99 --optimize=2 -g --misrac-version=201:
B_TASKING_TRICORE_ASM_OPT ...
B_TASKING_TRICORE_LD_OPTI ...

B_TASKING_TRICORE_LIB_INC B_TASKING_TRICORE_LD_OPTIONS= -Otcxyl --core=mpe:vtc
B_TASKING_TRICORE_LIBS

B_TASKING_TRICORE_PATH= C:\TriCore_v6.3rl\ctc

B8_TASKING_TRICORE_ASM_OPTIONS= --list-format=L1 --optimize=gs

LN N N N

#Include path f
#Each path pref
#B_TASKING_TR
8_TASKING_TRICORE_LIB

wing format as shown below.

B
INC:

shall

ith following format.

b name>][

B_TASKING_TRICORE_LIB! 1rt -lcs_fpu -1fp_fpu

« i D

& BaseFramework_TC39B/1_ToolEnv/0_Build/1_Config/Config_Tricore_Tasking/Config_Tasking.mk

Figure 3: Change path to TASKING VX-toolset for TriCore

6. Edit Config.xml in BaseFramework TC39B\1 ToolEnv\0 Build\1l Config and make the following changes:
a.Set primaryToolchain under architecture to Tasking.
b.Set enable under the Tasking toolchain to true (this should already be the case).

c. Set enable under all of the other toolchain entriesto false.

2 Bifaces_Aurix26_Workspace_V1_0_1_11_0 - BaseFramework_TC398/1_ToolEnv/0_Build/1_Cenfig/Configaxml - Eclipse Platform

File Edit Mavigate Search Project Run Design Window Help
(mf w R @-iBiQuiD AER A CRER AR Quick Access

[ Project Explorer 52 =%|s v=0 %] Configaml i2

» (25 BaseFramework_TC38A - mE T
4 5 BaseFramework_TC398 Node Content o
» (2= 05rc .
4 (= 1 ToolEnv
4 (= 0_Build
4 (= 1 Config
» (= Config_Tricore_Dec
. (= Config_Tricore_Ghs
» (= Config_Tricore_Gnuc

Primary architecture configuration
» [€] primaryArchitecture

S Architecture congfigurations
4 [g] architecture

name Tricore
| ® primaryToolchain Tasking

L. Target congfigurations

I

4 (= Config_Tricore_Taskin L
4 o - 9 = . [E] target
4 Config_Tasking.mk 5 —
@] Lcf Tasking_Tricore_Tc.lsl o Toolchain configurations
X BifacesConfigasd > [e] :"”:‘:”‘
Config.mk « [g] toolchain
neme Tasking
Configaml
o enable true
@ - path S(B_TASKING_TRICORE_PATH)\bin
82 Outline 5 5 =g configFolder $(B_CONFIG_FILES_FOLDER)/Config_Tricore_Tasking
o configFiles 1_ToolEnv/0_Build/L_Config/Cenfig.mk, Cenfig_Tasking.mk
77 xml
= » [€ tool
> [€] root xmins=http://www.infineon.com/BifacesCor = . o2
« i v

Design| Source

Figure 4: Edit Config.xml
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7. Add a Build target.
a. Double-click on Makefile.

b.In the Outline view right-click on all and select Add build Target.

£ Bifaces_Aurb@G_Workspace_V1_0_1_11_0 - BaseFramewark_TC33B/Makefile - Eclipse Platform =N EcR ==
File Edit Mavigate Search Project Run Window Help
Mg S Rat=H R B R R = Quick Access || 1% |[F)
[ Project Explorer 52 B S| T = 8 [ Makefile 52 = =

» S BaseFramework TC33A  seess -

> 122 BaseFramework_TC33AED
» 125 BaseFramework_TC35A
» 125 BaseFramework_TC36A
» 2 BaseFramework_TC37A
» 25 BaseFramework_TC38A
4 5 BaseFramework_TC398
(2 05rc
4 (= 1 ToolEnv

(7 0_Build
& Makefile

Copyright (c) 2618 Infineon Technologies AG. All rights reserved

IMPORTANT NOTICE

ER EXPRESS, IMPLIED
ANTIES OF

I R R R R R EEEE T

m

92 Qutline 532 | [E] Task List % v =08 SHELL = /bin/sh

® SHELL include $(BINUTILS PATH)/../Bifaces/Make/Root.mk
include S(BINUTILS_PATH)/ ..

-
Add build Target
clean:

leanmake
cleanmake :
ebuild
ndent rmall:
rebuild:
leandoc
rebuild indent:
ostbuild
doc:
cleandoc:

< b

Figure 5: Add a build target

8. Double-click on all under the just created Build Targets.

7 Project Explorer 2 == = =08

. =% BaseFramework_TC334A
. =% BaseFramework TC33AED
+ =% BaseFramework_TC354
+ =% BaseFramework_TC384
. =% BaseFramework TC3TA
+ =% BaseFramework TC384A
4 =% BaseFramewcrk_TC39B
) Build Targets
gy
4 = 1 _ToolEnv
. = 0_Build
Makefile

Figure 6: Build the project in BIFACES

The project will be built and the directory 9 Make will be created which contains the file Tricore IncludePathList.opt

that is needed in the TriCore Eclipse IDE.
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CREATE AN EMPTY PROJECT USING TRICORE ECLIPSE IDE

1. Start the TriCore Eclipse IDE.

2. From the File menu, select New » TASKING TriCore C/

C++ Project.

t:l TASKING C/C++ - TriCore Eclipse IDE vb 3rl
Edit Source Refactor Mavigate Search Project Debug  Window Help
Mew Alt+Shift+N b | [ TASKING MCS C Project

Open File... [&] TASKING PCP C Project
Close CrleW [] TASKING TriCore C/C++ Project
Close All Gy ||| PR E

[ TASKING ARM C/C++ Project
Save Ctrl+S = Project..

Figure 7: New TASKING TriCore C/C++ Project

3. Specify a project name (for example BaseFramework_
TC39B), select TASKING TriCore Application » Empty
Project and click Next.

tj New C/C++ Project = @

C/C+~+ Project
Create a new C/C++ project for the TASKING VX-toelset for TriCore

Project name:  BaseFramework_TC39B

Use default location

C:/Users/name/workspace_ctc_vG.3r1/BaseFramework_TC39I Browse...

Project type:
4 127 TASKING TriCore Application
@ Empty Project
@ Hello World C Project
@ Hello World C++ Project
. 127 TASKING TriCore Position Independent Module
- 127 TASKING TriCore Library
» 107 TASKING TriCore MIL Library

(‘3; < Back Next > Finish

Cancel

Figure 8: Project name / Empty Project

www.tasking.com

4. Select a processor. In this application note we select
TC39xB from the AURIX 2G Family.

5. Disable the actions Add startup file(s) to the project
and Add linker script file to the project and click Finish.

{ZJ New C/C++ Project

=5 BB =5

TriCore Project Settings

Set options to create a TriCore project

Processor selection

- [7] AUDO NextGeneration Family
» [] TC116x Family
- [7] AUDO Future Family
. [[] AUDO MAX Family
. [F] AUDQ S Family
. [[] AURX Family
a AURIX 2G Family
[ TC35x
[ TC36x
[ TC3x
[ TC38x
[ TCa9x
TC39xB

e dfi e a Tir oot 0

Expand All
Expand Selected
Collapse All

m

Multi-cere configuration

Use configuration: | All cores -

Actions

[7] &dd startup file(s) to the project
[T] Add linker script file to the project
[¥]Include debugger synchronization wtility

':?)' [ < Back ][ Mext > ] [ Finish ] [ Cancel

Figure 9: Project settings

Your C/C++ Projects view should now look like this:

= 0O

e -

4 =% BaseFramework TC39B [ Active - De
> [t Includes
- €] sync_on_halt.c

DCenfig

MConfig

OConfig

g C/C++ Projects &3

Figure 10: C/C++ Projects view
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COPY DATA FROM BIFACES TO THE TASKING ECLIPSE IDE PROJECT

1. Copy (Ctrl+C) 0_src from the BaseFramework project
(BaseFramework TC39B\0_Src)from BIFACES and
Paste (Ctrl+V) it in the BaseFramework project in the
TriCore Eclipse IDE.

< Bifaces_Aurix?G_Workspace_V1_0_1 11 0 - Eclipse Platform

File Edit Mavigate Search Project Run  Window Help
Tl |Bi®-iBiQ-ioF-if-dl-oa-D-

I Project Explorer &% = <§|)‘ ~ =08
» 2% BaseFramework TC33A

» 1=5 BaseFramework_TC334AED

» =% BaseFramework TC35A

» 1% BaseFramework_TC36A

» 15 BaseFramework_TCITA

» 1% BaseFramework_TC38A

Pl '_5 BaseFramewaork_TC39B

> (®) Build Targets
> |5 0_Src New 5
> (2= 1_ToolEnv
. = 2_0ut Ge Into
Makefile Open in New Window
Show in Local Terminal 3
IS Copy Ctrl+C
o Paste Ctrl+V

Figure 11: Copy 0_Src

2. Copy (Ctrl+C) Lcf Tasking Tricore Tc.lsl from
the BaseFramework project directory (BaseFramework
TC39B\1_ToolEnv\0_ Build\1l Config\Config
Tricore Tasking)and Paste (Ctrl+V)itin the
BaseFramework project in the TriCore Eclipse IDE.

2 Bifaces Aurix2G_Workspace V1 0.1 110 - Eclipse Platform
File Edit Mavigate Search Project Run Window Help
Hmid IEHORH = =T R IEUR R R R R N
(25 Project Explorer 52 2G| v =g
4 1% BaseFramework_TC398 -
. (@ Build Targets
5= 05
4 = 1 ToolEny
4 = 0 Build
4 (= 1 Config
. (= Config Tricore Dec
+ (= Config Tricore Ghs

New 3

Open
» (= Config Tricore Gnuc - .
4 (= Config_Tricore Tasking
& Config_Tesking.mk Show in Local Terminal 3
@] Lcf_Tasking_Tricore_Tc.lsl
8] Lt = = Co Ctri+C
¥| BifacesConfigasd B ony,
& Configrmk Paste Ctri+V
X Config:xmi % Delete Delete
- (= 9_Make Remove from Context Ctrl+ Alt+Shift+Down
> (= 2.0ut Mark as Landmark Ctrl+ Alt+Shift+Up
Makefil
@ Makelle Move...
< I} ¢ Rename... 2]

Figure 14: Copy LSL file

ﬁj TASKING C/C++ - TriCore Eclipse IDE v6.3r1
File Edit Source Refactor Mavigate Search Project Debug Window Help

= R | @~~~ @ il @ mw S i ® s
BE) C/C++ Projects &3 = 0
B =
4 |[=% BaseFramework_TC20B [ A-+=--—D-
> [ap) Includes MNew Y
> L sync_on_halt.c Go Into
=| DCenfig
=| MConfig Open in New Window
=| OConfig
Index 3
Build Configurations 3
Make Targets 3

Build Project

Clean Project

15 Copy
Paste

Figure 12: Paste 0_Src

{:] TASKING C/C++ - TriCore Eclipse IDE v6.2r1
File Edit Source Refacter Mavigate Search Project Debug Window Help
miS |B-&-E-@-il R - -ri® s
HZ) C/C++ Projects 2% = B8
les -
4 =5 BaseFramework_TC39B [ Active - De
> [ap Includes
> |z 0_Src
> €] sync_on_halt.c
=| DConfig
= MCeonfig
=| DConfig

Figure 13: Result

www.tasking.com

tj TASKING C/C++ - TriCore Eclipse IDE v6.3r1
File Edit Source Refactor MNavigate Search Project Debug Window Help

B H B E @ iR Wi i® s
@ C/C++ Projects 52 = 0
J;
CE
4 |=5 BaseFramework_TC39B [ A-+=--—D-
> [a)t Includes New '
+ [ 05 GoInto
> |g] sync_on_halt.c
=| DCenfig Open in New Window
= MCenfig
| OConfig Inee '
Build Configurations 3
Make Targets b

Build Project

Clean Project

5 Copy
Paste

¥ Delete

Figure 15: Paste LSL file

3. Copy (Ctrl+C) Tricore IncludePathList.opt

from the BaseFramework project directory
(BaseFramework TC39B\1 ToolEnv\O0_
Build\9 Make)and Paste (Ctrl+V)itin the
BaseFramework project in the TriCore Eclipse IDE.
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£ Bifaces_Aurb2G Workspace V1 0.1 11 0 - Eclipse Platform {4} TASKING C/C++ - TriCore Eclipse IDE v6.2r1
File Edit MNavigate Search Project Run Window Help ) ) ; - -
File Edit Source Refactor Mavigate Search Project Debug Window Help
el S @ iDiIQ i A iE A ErD )
i o ¥ 5 . . 5 5 5
| M | R &~ - @ il @ W S -4
I Project Explorer 33 = <§‘;| =0
4 522 BaseFramework TC39B . Hg) C/C++ Projects &3 =
, @ Build Targets ==
> = 0_Src | -4)
a4 |l=% BaseFramework_TC39B [ *-+~--—-
4 (= 1_ToolEnv Mew v
4 (= 0_Build > [ Includes
> (= 1_Config > = 0_Src G
o Into
4 (= 9 Mske bl ' > [€] sync_on_halt.c
e GD’::: . Open =| DConfig Open in New Window
ines.ml
e Open With » ksl Lef_Tasking_Tricore_Tc
& Projectmk P = ] Index N
& ProjectDep.mk Show in Local Terminal 3 =| MConfig
5| Tricore IncludePathList.opt| =| OConfig Build Configurations 3
- Tricore_Tc_ObjList.opt B Copy Ctil+C P ,
= 2.0ut Paste Ctr+V
& Makefile % Delete Delete Build Project
Clean Project
Figure 16: Copy include path list
g Py p B Ccopy
T, Paste

Figure 17: Paste include path list

ADAPT THE TASKING ECLIPSE IDE PROJECT

1. Open Tricore IncludePathList.opt andchangeall 0 Src/ pathsto../0 Src/ and Save(Ctrl+S) the file.

{J) TASKING C/C++ - BaseFramework_TC39B/Tricore _IncludePathList.opt - TriCore Eclipse IDE v6.311 (I TASKING C/C++ - BaseFramework_TC39B/Tricore_IncludePathList.opt - TriCore Eclipse IDE v6.3il
File Edit Source Refactor Navigate Search Project Debug Window Help File Edit Source Refactor MNavigate Search Project Debug Windew Help
Huls ICAMCANCRNCASPATR R R R SRR NTiFR A R ASRCR AR (=g |Biv g &S - @ L@@ H-®FEH LoD
Quick Acces: Quick Acces:
Ry C/Ce+ Projects 52 = O |[[D) Tricore IncludePathListopt 53 =g @ c/Cs+ Projects 52 = 8 |[[2 Tricore IncludePathList.opt i3 = B8
Bk v "-10_Src/Appsw/CpuGeneric/Config” - les <~ *-I../@_Src)rppSw/CpuGeneric/Config” P

[Active - -Te_Src/ppSu/Tricore/Cig_Ssw” 1. .76 Src fappsu/Tricore/CFg_Ssu”
4 € BaseFramework TC39B [Active - Dl 107 fpncesw/iLLo/TC3987Tricore”

4 5 BaseFramework TC398 [ Active - D "-I../8_Src/Basesw/iLLD/TC398/Tricore”

» ) Includes "|-16_Srec/BaseSw/Service/CpuGeneric/_Utilities” > [ Includes "I-1../@_Src/BaseSw/Service/CpuGeneric/_Utilities”
» & 05 "l-Te_Src/BaseSw/iLLD/TC398/ Tricore/ Inpl” > 0.5 "-I../6_src/Basesw/iLLD/TC39B/ Tricore/_Inp
» @ sync_on_halt.c "|-10_Src/BaseSw/iLLD/TC398/Tricore/_PinMap” » [8 syncon_haltc "I-I../@_Src/Basesw/iLLD/TC398/Tricore/ PinMap”
5 DConfig "l-16_Src/BaseSw/Infra/Platforn/Tricore/Conpilers” DConfig |1 -/e_Sre fBasesu/ Infra/Platform/ Tricore/ Conpilers”

"I-10_src/Basesw/Infra/Sfr/TC398/ Reg”

i "I-1../@_Src/BaseSw/Infra/sfr/TC398/_Reg”
4 Lef Tasking Tricore Tell "I-18_Src/BaseSw/Infra/Ssw/TC39B/ Tricore”

) Lef_Tasking Tricore Tes! 7-1../8_Src (BaseSu/Infra/5sw/TC398/ Tricore”

5| MCenfig "I-10_Src/{BaseSw/iLLD/TC39B/ Tricore/Cpu/Trq” MCenfig "|-1../@_Src/|Basesw/ilLD/TC39B/Tricore/Cpu/Irq”
QConfig "|-T@_Src/BaseSw/iLLD/TC39B/Tricore/Cou/Std OConfig ’|-1../@_Src/BaseSw/iLLD/TC39B/Tricore/Cpu/Std"

| Tricore IncludePathList.opt "l-18_Src/{Basesw/1LLD/TC398/ Tricore/Cpu/Tra Tricore IncludePathList.opt "-I../8_Src/|BaseSw/iLLD/TC398/Tricore/Cpu/Trap”
"l-19_Src/BaseSw/iLLD/TC39B/Tricore/Dma/Dma” "-1../8_SreBasesw/iLLD/TC398/Tricore/Oma/Dma"
"l-18_Src/{Basesw/1LLD/TC398/ Tricore/Dma/std" "-1../8_Src/|Basesw/iLLD/TC398/Tricore/oma/std"
"l-19_Src/BaseSw/iLLD/TC39B/ Tricore/Mtu/Std" "-1../8_Src/Basesw/iLLD/TC398/Tricore/Mtu/Std"
"l-18_Src/{Basesw/1LLD/TC398/ Tricore/Pms/Std" "-I../8_Src/BaseSw/iLLD/TC398/ Tricore/Pms/Std”
"l-19_Src/BaseSw/iLLD/TC39B/ Tricore/Port/Io" "-1../@_Src/|BaseSw/iLLD/TC398/Tricore/Fort/To"
"l-10_Src/Basesw/1LLD/TC398/ Tricore/Port/Std" 7-I../8_Src/|Basesw/iLLD/TC398/ Tricore/Port/Std"
"|-T6_Src/BaseSw/iLLD/TC398/ Tricore/Seu/std "-1../8_Src/Basesw/iLLD/TC398/Tricore/Scu/std"
"l-10_Src/{Basesw/1LLD/TC398/ Tricore/Src/std” "-I../8_Src/Basesw/iLLD/TC398/Tricore/Src/std”
"l-10_Src/Basesw/iLLD/TCI0B/ Tricore/Stm/Std" "-1../8_Src/|BaseSw/iLLD/TC398/ Tricore/Stm/Std"
"l-10_Src/Basesw/1LLD/TC398/ Tricore/_Lib/Internaldux” "-1../@_Src/BaseSw/iLLD/TC398/Tricore/_Lib/Internaliux”
"l-Te_Src/BaseSw/Infra/sfr/TC398" "-I../8_Src/BaseSw/Infra/Sfr/TC398"
"l-10_src/fBasesw/Infra/Platform/Tricore” "-1../8_Src/Basesw/Infra/Platform/Tricore”
"l-10_src/Basesw/Infra/Platforn” "-1../8_Src/Basesw/Infra/Platforn”
"|-18_Src/BaseSw/Service/CpuGeneric” "-1../8_Src/Basesw/Service/CpuGeneric”

Figure 18: Open the options file Figure 19: Add ../ to include path
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2. Disable Automatic inclusion of ".sfr' file from the Properties dialog (Project » Properties for project name, C/C++
Build » Settings» Tool Settings » C/C++ Compiler » Preprocessing).

w Properties for BaseFramework_TC39B = @

type filter text Settings =10 4 r v
- Resource
Builders e
a4 C/C++ Build Configuration: [Debug [ Active ] '] [Manage Configurations...

Build Variables
Environment

Logging ¥ Tool Settings | Build Stepsl Build Amfactl Binary Par;ersl @ Error Par;ers|
Processor
Settings @ Global Options [] Automatic inclusion of sfr' file ‘
> C/C++ General 4 ) C/C++ Compiler || Store preprocessor output in <file> pre
Project References (% Preprocessing Keep comments in preprocessor cutput =
il 1 o)
» Run/Debug Settings (£ Include Paths Keep #line info in preprocessor output
(5 Precompiled C++ Headers
(2 Langusge Defined symbols &

(2 Floating-Point
@ Code Generation
(2 Allocation
4 (B Optimization
@ Custom Optimization
@ Compilation Speed
(22 Debugging Pre-include files L=
a (2 MISRA C
(2 Custom 2012
(5 Custorn 2004
(2 Custom 1998
a @ CERT € Secure Ceding
(% Custom CERT C
(2 Diagnostics
(2 Miscellaneous
4 B8 Assembler
@ Preprocessing

L) oK ] [ Cancel

Figure 20: No automatic inclusion of SFR file

3. Add -f "path_to_opt file\Tricore IncludePathList.opt"to the Additional optionsfield (Project » Properties
for project_ name, C/C++ Build » Settings» Tool Settings » C/C++ Compiler » Miscellaneous), where path_to_opt file
is the absolute path to the option file.

L} Properties for BaseFramework_TC398 =[]
typefilter text Settings R
 Resource
Builders
4 C/C+ Build Configurstion: Debug [ Active ]

=] [Manage Configurations

Build Variables
Environment

Logging 1) Tool Settings | & Build Steps | " Build Artifact | [iry Binary Parsers | @ Error Parsers
Memory
Processor (2 Global Options [¥] Merge C source code with generated assembly
Settings 4 1) C/C++ Compiler Force definition of virtual function table:
Stack/Heap (5 Preprocessing Suppress definition of virtual function table: =
g Y
> C/Cr General & Include Paths Tmplicit ion of source files for finding templates
Project References (Z3 Precompiled o+ Headers Vil infining of ol (Coe
= 4 Minimal inlining of function calls (C++)
. Run/Debug Settings (3 Language
(3 Floating-Peint Used

(2 Code Generation
(2 Allocation
2 (5 Optimization |Additional options: 4G - ctc_v6.31  TC39B\Tricore IncludePathList.opt”
(& Custom Optimization
(£ Compilation Speed
(2 Debugging
4 (8 MISRAC
(i Custom 2012
(& Custom 2004
(2 Custom 1998
4 (5 CERT C Secure Cading
(5 Custom CERT €
(8 Diagnostics
(% Miscellaneous
4 1) Assembler
(2 Preprocessing

Comment n object file:

®

Figure 21: Add options file to the additional options
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4. Select Lcf Tasking Tricore Tc.lsl as Linker Script File (Project » Properties for project name, C/C++ Build »
Settings» Tool Settings » Linker » Script File). You can use the Browse button to look for the file.

(.} Properties for BaseFramework_TC398 =
type filter text Settings T D
» Resource
Builders =
4 CfCos Build c [Debug [ Active] ~] [Manage

Build Variables
Environment

Logging 1) Tool Settings | & Build Steps | /1" Build Artifact | by Binary Parsers | @ Error Parsers,
Wemory
Pracessor (5 Global Options Defined symbols a
Settings » ) C/C++ Compiler
Stack/Heap » B Assembler
» C/C++ General 4[1 Linker
Project References £ Patching L
» Run/Debug Settings % Output Format i
5 Libraries

3 Data Object:
=2 L oblets Linker script file | CA\L - cte V6310 . TC39B\Lcf_Tasking_Tricore_Tc.lsl Brows
53 Script File

% Optimization
53 Map File

% Diagnostics
 Miscellaneous

Figure 22: Specify LSL file

BUILD THE PROJECT

1. From the Project menu, select Build <project-name> (or select Rebuild <project-name> to do a rebuild).

2. Check if any errors occurred. If an error occurred with include paths, please check and adapt Tricore
IncludePathList.opt accordingly.

{.J TASKING C/C++ - BaseFramework_TC398/Tricore IncludePathList.opt - TriCore Eclipse IDE v6.3r1 o ==
File Edit Source Refactor Navigate Search Project Debug Window Help
[mif 2 b G- -l n T DiE® P T e
Quick Access | (3 | [[E] TASKING C/Cr
() C/C++ Projects &3 = 8 || B Tricore_IncludePathlist.opt 2 = 8 |[8= Outline 22 = B8
5% v . ./8_Src/AppSw/CpuGeneric/Config” -
— ../8_Src/RppSw/Tricore/Cfg_Ssw"
[- ewor . = .
af® BaseFramework TC30B [ Active - D o ore/Bubeon/ LD/ TC39] Tricore™ An outline is not available.
> 4% Binaries ../8_Src/BaseSw/Service/CpuGeneric/ Utilities"
> il Includes ../8_Src/BaseSw/ilLD/TC388/Tricore/_Impl"
b & 0_Sre ../8_Src/BaseSw/ilLLD/TC398/Tricore/_PinMap™
4 = Debug ../@_src/Basesw/Infra/Platform/Tricore/Compilers”
0 S ..78_Src/BaseSw/Infra/Sfr/TC39B/_Reg”
> &0 ../@_5rc/Basesw/Infra/Ssw/TC39B/ Tricore”
+ |3 BaseFramewark _TC39B.elf - [Tt /@_Src/BaseSw/ilLD/TC398/Tricore/Cpu/Irq”
b 4 sync_on_halt.o - [TriCore/le] @_Src/BaseSw/ilLLD/TC39B/Tricore/Cpu/Sti
1] halt.o - [TriCore/le] /8_src/! /iLLD/ /Tricore/Cpu/Std"”
[E) BaseFramewark_TC39B.mapxn /8_Src/BaseSw/iLLD/TC398/Tricore/Cpu/Trap”
= BaseFramework TC39B.mdf ../8_Src/BaseSw/ilLD/TC398/Tricore/Dma,/Dma"
D el - ../8_Src/BaseSw/ilLD/TC398/Tricore/Dma/Std"”
consoledog ../8_Src/BaseSw/ilLD/TC398/Tricore/Mtu/Std"
& makefile ../8_Src/BaseSw/ilLD/TC398/Tricore/Pms/Std"
® subdir.mk ../8_Src/BaseSw/ilLLD/TC398/Tricore/Port/Io"
sync_on_halt.src ../@_Src/Basesw/iLLD/TC398/Tricore/Port/std"
Y @ sync_on_halt.c ../8_Src/BaseSw/iLLD/TC398/Tricore/scu/std”
> DConfig. ..78_S5rc/BaseSw/ilLD/TC398/Tricore/Sre/Std”
- 9 ..78_S5rc/BaseSw/ilLD/TC398/Tricore/Stn/Std”
e Lef_Tasking_Tricore_Te.ls! /8_Src/BaseSw/ilLD/TC398/Tricore/_Lib/Internalbux”
=| MConfig /8_Src/BaseSw/Infra/sfr/TC398"
=| OConfig ../@8_Src/BaseSw/Infra/Platform/Tricore”
2| Tricare_IncludePathList.opt ../8_5rc/BaseSw/Infra/Platform”
../8_Src/BaseSw/Service/CpuGeneric”
a »
[21 Problems | B Console 2 ._[C] Properties & (B HEE x M B-cg-= 08
CDT Build Console [BaseFramework_TC398]
Compiling Tfx_Ssw_Tc5.c =
Linking to BaseFramework_TC39B.elf
Time consumed: 18488 ms
#xx% £nd of build ****
« i vl f
/BaseFramework_TC39B/Debug/BaseFramework_TC39B.elf

Figure 23: Build result

The project is now ready.

This concludes the Application Note on how to migrate from BIFACE to the TASKING TriCore Eclipse IDE.
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